We have temporarily paused deposits and withdrawals for MANTRA (MANTRA).
Trading remains available. We are monitoring the situation closely and will provide an update as soon as we have more information. For the latest updates directly from MANTRA, please refer to their official status page.
Thank you for your patience and understanding.
Identified
We have temporarily paused deposits and withdrawals for MANTRA (MANTRA).
Trading remains available. We are monitoring the situation closely and will provide an update as soon as we have more information. For the latest updates directly from MANTRA, please refer to their official status page.
Thank you for your patience and understanding.
Identified
We have temporarily paused deposits and withdrawals for MANTRA (OM).
Trading remains available. We are monitoring the situation closely and will provide an update as soon as we have more information. For the latest updates directly from MANTRA, please refer to their official status page.
Thank you for your patience and understanding.