Following the security incident involving the Kite Foundation, Bitvavo will support the KITE (KITE) contract swap on the Ethereum (ERC-20) network.
- The contract swap will take place on Thursday, 20 August 2026, at a 1:1 ratio. No action is required on your side.
- Deposits and withdrawals of KITE via the Ethereum (ERC-20) network will remain closed until the swap is completed, and will reopen once the swap has been finalized.
- Trading will continue as normal throughout the contract swap.
- After the migration, your deposit address will remain the same. As always, we recommend verifying it on the deposit page before sending funds.
We will keep you informed of any further updates.
Monitoring
Following the security incident involving the Kite Foundation, Bitvavo will support the KITE (KITE) contract swap on the Ethereum (ERC-20) network.
- The contract swap will take place on Thursday, 20 August 2026, at a 1:1 ratio. No action is required on your side.
- Deposits and withdrawals of KITE via the Ethereum (ERC-20) network will remain closed until the swap is completed, and will reopen once the swap has been finalized.
- Trading will continue as normal throughout the contract swap.
- After the migration, your deposit address will remain the same. As always, we recommend verifying it on the deposit page before sending funds.
We will keep you informed of any further updates.
Identified
We have paused crypto withdrawals and deposits for KITE as a precautionary measure, due to a security incident outside of Bitvavo and reported by the Kite Foundation.
We are monitoring the situation and we will update you as soon as we have new information.
Thank you for your patience and understanding.
Identified
We have paused crypto withdrawals and deposits for KITE due to a security incident on their side. Users may experience delays in processing crypto withdrawals.
We are monitoring the situation and we will update you as soon as we have new information.
Thank you for your patience and understanding.