The technical issues affecting the Pro Mode web interface have been fully resolved. Our engineering team has implemented a fix, and all modules, including charts and order execution, are now functioning as expected across all browsers.
We appreciate your patience while we worked to restore full service. Please note that all customer funds remained safe throughout this period. If you are still experiencing any display issues, we recommend refreshing your page or clearing your browser’s cache.
Resolved
The technical issues affecting the Pro Mode web interface have been fully resolved. Our engineering team has implemented a fix, and all modules, including charts and order execution, are now functioning as expected across all browsers.
We appreciate your patience while we worked to restore full service. Please note that all customer funds remained safe throughout this period. If you are still experiencing any display issues, we recommend refreshing your page or clearing your browser’s cache.
Investigating
We are currently investigating reports of technical difficulties with our Pro Mode web interface. Some users may experience issues with charts loading or placing orders via the advanced panel.
In the meantime, you can still execute trades, deposits, and withdrawals using the Standard Bitvavo interface or the Mobile App.
Your funds remain safe and unaffected. We are working to restore full functionality as quickly as possible.