Cloudflare outage affecting multiple services
Resolved·Degraded performance

After thorough testing and monitoring to ensure that everything is functioning as expected we can now close the incident. If you encounter any further issues or have any questions, please don't hesitate to reach out to us. Thank you for again your cooperation and understanding throughout this process.

Fri, Dec 5, 2025, 10:41 AM
(2 hours ago)
·
Affected components
Logins
Updates

Resolved

After thorough testing and monitoring to ensure that everything is functioning as expected we can now close the incident. If you encounter any further issues or have any questions, please don't hesitate to reach out to us. Thank you for again your cooperation and understanding throughout this process.

Fri, Dec 5, 2025, 10:41 AM

Monitoring

Our team has implemented the necessary fixes, and we are currently monitoring the situation thorough testing to ensure that everything is functioning as expected. If you encounter any further issues or have any questions, please don't hesitate to reach out to us. Thank you for your cooperation and understanding.

Fri, Dec 5, 2025, 09:32 AM(1 hour earlier)

Investigating

We’re currently experiencing accessibility issues across our platform. As a result, some users may be unable to access Bitvavo at this time. Our team is actively monitoring the situation and working closely with Cloudflare to ensure services return to normal as soon as possible. We’ll provide updates as soon as more information becomes available. Thank you for your patience and understanding.

Fri, Dec 5, 2025, 09:14 AM(17 minutes earlier)

Investigating

We’re currently experiencing accessibility issues across our platform. As a result, some users may be unable to access Bitvavo at this time. Our team is actively monitoring the situation and working closely with Cloudflare to ensure services return to normal as soon as possible. We’ll provide updates as soon as more information becomes available. Thank you for your patience and understanding.

Fri, Dec 5, 2025, 09:08 AM