We have identified the rootcause of the issue affecting proof of address verification for German users. We are now exploring the best solution to restore normal verification as soon as possible. German customers can still access their Bitvavo account, but uploading proof of address is not possible until this is fixed. We will keep you updated on our progress.
Identified
We have identified the rootcause of the issue affecting proof of address verification for German users. We are now exploring the best solution to restore normal verification as soon as possible. German customers can still access their Bitvavo account, but uploading proof of address is not possible until this is fixed. We will keep you updated on our progress.
Investigating
We are currently investigating an issue affecting the proof of address verification process. Some customers may experience delays or errors when uploading or submitting their documents. Our team is working to identify the cause and restore normal processing as quickly as possible. Customers can continue using their Bitvavo account as usual, but new identity verification steps requiring proof of address may not complete until this is resolved. We’ll share an update as soon as we have more information. Thank you for your patience.