Fiat Deposits
Resolved·Degraded performance

Our team has implemented the necessary fixes, and we have conducted thorough testing. We can confirm that Mastercard Credit Cards payments are now fully functional and working as expected. If you encounter any further issues or have any questions, please don’t hesitate to reach out to us. Thank you for your cooperation and understanding throughout this process.

Fri, Sep 12, 2025, 06:02 PM
(4 days ago)
·
Affected components
Fiat Deposits
Updates

Resolved

Our team has implemented the necessary fixes, and we have conducted thorough testing. We can confirm that Mastercard Credit Cards payments are now fully functional and working as expected. If you encounter any further issues or have any questions, please don’t hesitate to reach out to us. Thank you for your cooperation and understanding throughout this process.

Fri, Sep 12, 2025, 06:02 PM

Investigating

We are currently experiencing technical difficulties, which may cause delays in fiat deposits from Master Card credit cards which is currently not available. Our team is actively working on diagnosing the situation and will be updating you as soon as possible. Thank you for your patience and understanding.

Thu, Sep 11, 2025, 09:41 AM(1 day earlier)