Delayed Fiat Withdrawals
Resolved·Degraded performance

After thorough testing and monitoring to ensure that everything is functioning as expected we can now close the fiat withdrawals incident. If you encounter any further issues or have any questions, please don't hesitate to reach out to us. Thank you for again your cooperation and understanding throughout this process.

Fri, Jun 6, 2025, 08:32 AM
(1 month ago)
·
Affected components
Fiat Withdrawals
Updates

Resolved

After thorough testing and monitoring to ensure that everything is functioning as expected we can now close the fiat withdrawals incident. If you encounter any further issues or have any questions, please don't hesitate to reach out to us. Thank you for again your cooperation and understanding throughout this process.

Fri, Jun 6, 2025, 08:32 AM

Monitoring

Our team has implemented the necessary fixes, and we see that withdrawals are being processed again. We are currently monitoring the stability of the fix and we will provide updates when needed. Thank you for your cooperation and understanding throughout this process.

Fri, Jun 6, 2025, 07:20 AM(1 hour earlier)

Identified

We are pleased to inform you that we have identified the root cause of the fiat withdrawals issue. We are now proceeding with the necessary steps to address and resolve the issue. We will keep you updated on our progress.

Fri, Jun 6, 2025, 06:47 AM(33 minutes earlier)

Investigating

We are currently experiencing technical difficulties, which may cause delays in fiat withdrawals. Our team is actively working on diagnosing the situation and will provide you with an update as soon as possible. Thank you for your patience and understanding.

Fri, Jun 6, 2025, 05:52 AM(54 minutes earlier)