Scheduled Maintenance
Complete·Under maintenance

We have completed the maintenance and all delays are back to normal processing times.

We apologise for the inconvenience and appreciate your patience.

Thu, Jun 5, 2025, 06:44 AM
(2 days ago)
·
Affected components
Fiat Deposits
Fiat Withdrawals
Crypto Deposits or Withdrawals
Assets
Updates

Complete

We have completed the maintenance and all delays are back to normal processing times.

We apologise for the inconvenience and appreciate your patience.

Thu, Jun 5, 2025, 06:44 AM

In progress

Due to maintenance, an old message regarding a past crypto deposit or withdrawal may have been mistakenly re-sent. Please disregard it.

Currently, crypto deposits and withdrawals are experiencing delays. We are actively working to resolve the issue as quickly as possible. Your funds are safe.

Thu, Jun 5, 2025, 05:33 AM(1 hour earlier)

Complete

Maintenance has completed

Thu, Jun 5, 2025, 05:00 AM(33 minutes earlier)

In progress

Maintenance has started

Thu, Jun 5, 2025, 04:00 AM(1 hour earlier)

Scheduled

We will be performing a scheduled maintenance on Thursday, June 5th from 06:00 AM to 07:00 AM CEST.

During this maintenance window, the following features are impacted:

  • Delay in deposits and withdrawals, impacting both fiat and crypto

  • Delay in updates in the portfolio chart

  • Delay in seeing an update in your user balance

  • You might experience delays during account verification

All delays will be processed after the maintenance window has been closed. Updates regarding any potential impact will be provided if necessary.

We appreciate your patience as we work to enhance our platform. If you have any questions, please don't hesitate to contact our support team.

Wed, Jun 4, 2025, 01:12 PM(14 hours earlier)