Resolved
We're happy to let you know that euro deposits are now working as expected on both the mobile app and the web platform. The issue has been resolved and a fix has been applied. Thank you for your patience and understanding.
Investigating
Unfortunately, we're still unable to reopen deposits, as our partner is continuing to experience issues with their deposit service. Their team is actively working to resolve the problem as quickly as possible. We'll share updates as we make progress. Thank you for your patience and understanding.
Monitoring
We've identified the cause of the issue. Our payment partner, Adyen, experienced a disruption with the relevant service. The situation is now being resolved, and deposits should be available again within approximately 15 minutes. Thank you for your patience and understanding.
Investigating
We're currently experiencing an issue affecting fiat deposits on the platform, which is preventing users from initiating deposits. Our engineering team is actively investigating the cause, and we’ll share updates as soon as we make progress. Thank you for your patience and understanding.