Scheduled Maintenance
Complete·Under maintenance
Sun, Mar 2, 2025, 06:00 AM
(4 months ago)
·
Affected components
Logins
Fiat Deposits
Fiat Withdrawals
Crypto Deposits or Withdrawals
Buy & Sell Crypto
Staking
Assets
API
Mobile App
Website
SMS
Updates

Complete

Maintenance has completed

Sun, Mar 2, 2025, 06:00 AM

In progress

Maintenance has started

Sun, Mar 2, 2025, 02:00 AM(3 hours earlier)

Scheduled

We will perform a scheduled maintenance on the 2nd of march from 03:00 to 07:00 CET.

All operations (orders, deposits and withdrawals) will be suspended during the maintenance window.
Once the upgrade is complete, we will begin with a halted state of the markets to allow new orders to be placed. Following this halt, the markets will transition into an auction phase, and regular trading will resume shortly after.


Updates regarding any potential impact will be provided if necessary.
Thank you for your patience as we work to improve our platform. If you have any questions, please reach out to our support team.

Fri, Feb 21, 2025, 03:56 PM(1 week earlier)