Technical issues impacting platform availability
Resolved·Full outage

Earlier today, some users experienced temporary availability issues on our platform. A planned upgrade caused an unexpected issue that briefly impacted certain functionalities.

Our team quickly identified the issue and restored functionality. In applying the required fixes the platform was temporarily unavailable. All services were back operational at 12:20h CET.

We apologize for any inconvenience this may have caused and appreciate your patience. If you still experience any issues, please reach out to our support team.

Thu, Feb 20, 2025, 11:30 AM
(6 months ago)
·
Affected components
Fiat Deposits
Fiat Withdrawals
Crypto Deposits or Withdrawals
Buy & Sell Crypto
Assets
Updates

Resolved

Earlier today, some users experienced temporary availability issues on our platform. A planned upgrade caused an unexpected issue that briefly impacted certain functionalities.

Our team quickly identified the issue and restored functionality. In applying the required fixes the platform was temporarily unavailable. All services were back operational at 12:20h CET.

We apologize for any inconvenience this may have caused and appreciate your patience. If you still experience any issues, please reach out to our support team.

Thu, Feb 20, 2025, 11:30 AM

Resolved

Issue resolved. All services are available.

Thu, Feb 20, 2025, 11:26 AM

Monitoring

We have applied relevant fixes and are preparing to have our platform back online between 12:00 and 12:15h.

Thu, Feb 20, 2025, 10:46 AM(40 minutes earlier)

Identified

We have identified the issue and our team is actively working to resolve the root cause as quickly as possible.

We will keep this statuspage up to date with the latest information.

We apologize for the inconvenience and appreciate your patience.

Thu, Feb 20, 2025, 09:36 AM(1 hour earlier)

Investigating

We are currently encountering a technical issues causing our platform to be offline.

You might experience issues when attempting to:

  • Seeing your available up-to-date balance.

  • Withdrawing or depositing your balance.

  • Buying or selling an asset.

  • Withdrawing or depositing crypto assets

Deposits are still being processed. However the balance you are seeing might not yet be updated.

Our team is actively working to resolve the issue and restore the functionality as soon as possible.

Thu, Feb 20, 2025, 08:52 AM(44 minutes earlier)