Resolved
The incident has been resolved. Crypto withdrawals are available again.
We apologize for the inconvenience caused and appreciate your patience as we worked to resolve this incident.
Monitoring
We have implemented a fix and are seeing improvements in availability.
We will continue monitoring for any instabilities and will update this incident once it is resolved.
Investigating
We are currently encountering a technical issue impacting the functionality of withdrawing crypto assets. You might experience an infinite loading screen or time-out when attempting to withdraw your assets.
Other related features, like crypto deposits and FIAT withdrawals are still available.
Our team is actively working to resolve the issue and restore the functionality as soon as possible.