Delayed Crypto Withdrawals
Resolved·Degraded performance

Processing time of all crypto withdrawals is now back to normal.

Thu, May 2, 2024, 12:31 PM
(1 year ago)
·
Affected components
Crypto Deposits or Withdrawals
Updates

Resolved

Processing time of all crypto withdrawals is now back to normal.

Thu, May 2, 2024, 12:31 PM

Monitoring

We are currently processing withdrawals for a small number of ERC20 tokens with a minor delay, processing time for all other assets is back to normal. The team will continue to monitor during the night.

Wed, May 1, 2024, 07:43 PM(16 hours earlier)

Identified

We have processed most of the delayed withdrawals. Our team is continuing to work on the remaining withdrawals and improving our systems further. Thank you for your continued patience.

Wed, May 1, 2024, 05:40 PM(2 hours earlier)

Identified

We are still seeing increased waiting times on the processing of crypto withdrawals, expected additional waiting time is up to 8 hours. Our team continues to optimize our processes to speed up crypto withdrawals. Thank you for your continued patience.

Wed, May 1, 2024, 10:36 AM(7 hours earlier)

Identified

The crypto withdrawals incident is still under investigation.

Our team continues to analyze the situation to identify the root cause of the incident.

Thank you for your continued patience.

Wed, May 1, 2024, 08:26 AM(2 hours earlier)

Identified

We are currently experiencing delays in crypto withdrawals.

Our team is actively working on diagnosing the situation and will provide you with an update as soon as possible.

Thank you for your patience and understanding.

Wed, May 1, 2024, 07:49 AM(36 minutes earlier)