Our team has implemented the necessary fixes, and we have conducted thorough testing to ensure that everything is functioning as expected.
If you still encounter any delays during the ID verification or if you have any questions, please don't hesitate to reach out to us.
Thank you for your cooperation and understanding throughout this process.
Resolved
Our team has implemented the necessary fixes, and we have conducted thorough testing to ensure that everything is functioning as expected.
If you still encounter any delays during the ID verification or if you have any questions, please don't hesitate to reach out to us.
Thank you for your cooperation and understanding throughout this process.
Investigating
We’re investigating an issue causing slowness related to ID verification.
The ID verification may take longer to be completed as a result of this, but no extra actions need to be taken by the customer.
Our team is working on a fix and will update you as soon as possible.
Thank you for your patience